Total members 11890 |It is currently Sat Apr 20, 2024 4:51 am Login / Join Codemiles

Java

C/C++

PHP

C#

HTML

CSS

ASP

Javascript

JQuery

AJAX

XSD

Python

Matlab

R Scripts

Weka





Since milk packaging is such a low margin business, it is important to keep the price of the raw product (milk) as low as possible. Help Merry Milk Makers get the milk they need in the cheapest possible manner.

The Merry Milk Makers company has several farmers from which they may buy milk, and each one has a (potentially) different price at which they sell to the milk packing plant. Moreover, as a cow can only produce so much milk a day, the farmers only have so much milk to sell per day. Each day, Merry Milk Makers can purchase an integral amount of milk from each farmer, less than or equal to the farmer's limit.

Given the Merry Milk Makers' daily requirement of milk, along with the cost per gallon and amount of available milk for each farmer, calculate the minimum amount of money that it takes to fulfill the Merry Milk Makers' requirements.

Note: The total milk produced per day by the farmers will be sufficient to meet the demands of the Merry Milk Makers.
PROGRAM NAME: milk
INPUT FORMAT
Line 1: Two integers, N and M.
The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers' want per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from.
Lines 2 through M+1: The next M lines each contain two integers, Pi and Ai.
Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges.
Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

SAMPLE INPUT (file milk.in)

100 5
5 20
9 40
3 10
8 80
6 30

OUTPUT FORMAT

A single line with a single integer that is the minimum price that Merry Milk Makers can get their milk at for one day.
SAMPLE OUTPUT (file milk.out)

630

The solution by ACM student :
Code:
/*

PROG: milk
*/



#include <iostream>
#include <fstream>
#include <string>
#include <iomanip>
#include <algorithm>
#include <vector>
#include <math.h>
#include <stdlib.h>
#include <stdio.h>
using namespace std;

/* Greedy solution. Sort by ascending price
and pick up the items. */

void main()
{
  fstream fin,fout;
  int i,a,b;
  fin.open("milk.in",ios::in);
  cin=fin;
  fout.open("milk.out",ios::out); 

  int qty,farmers;
  vector<int> price;
  vector<int> qt;
  cin >> qty >> farmers;
 
  for (int k=0; k<farmers; k++)
  {
    cin >> a >> b;
    int l;
    for (l=0; l<price.size() && (a>price[l]); l++);
    price.insert(price.begin()+l,a);
    qt.insert(qt.begin()+l,b);
  }

  int cost=0;
  int curptr=0;
  while (qty>0) {
    if (qty>qt[curptr]) {
      qty-=qt[curptr];
      cost+=price[curptr]*qt[curptr];
    } else {
      cost+=price[curptr]*qty;
      qty=0;
    }
    curptr++;
  }

  fout << cost << endl;
 
  fout.close();   
}




_________________
M. S. Rakha, Ph.D.
Queen's University
Canada


Author:
Mastermind
User avatar Posts: 2715
Have thanks: 74 time
Post new topic Reply to topic  [ 1 post ] 




Topic Tags

C++ Algorithms
cron





Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
All copyrights reserved to codemiles.com 2007-2011
mileX v1.0 designed by codemiles team
Codemiles.com is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to Amazon.com